[3dem] motioncorr fails to initialize GPU

Michele Lunelli michlun23 at gmail.com
Fri Jun 17 06:52:10 PDT 2016

Dear all,

I am having trouble in running motioncorr on a machine running Scientific
Linux 7.2 with a nvidia GPU Quadro K620 with 2 GB of memory.
nvidia-smi correctly recognize the GPU, but gpuinfo tells me:

You have 1 nVidia GPGPU.

DeviceID Name             Version Memory(Mb)
Failed to get GPU info of Device #0

When I run dosefgpu_driftcorr I get:

Input Stack: Nx(4096) Ny(4096) Nz(7)

Crop Image: Offset(0 0) Dim(4096 4096)

Allocate host memory: 1.062988 Gb
Error: Failed to set CUDA Device #0. Abort.
Failed to initialize GPU #0.

Trying other devices doesn't change anything.

I am using CUDA 7.5 and nvidia drivers version 340.96. I tried to compile
the program either with g++ 4.4.7 or 4.8.5, but I got the same errors.

Thank you in advance for any suggestion,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.ncmir.ucsd.edu/pipermail/3dem/attachments/20160617/609f6216/attachment.html>

More information about the 3dem mailing list